ePay - Issue identified with MidID – Incident details

All systems operational

Issue identified with MidID

Resolved
Degraded performance
Started 7 days agoLasted 41 minutes

Affected

MitID

Degraded performance from 9:25 AM to 10:06 AM

Updates
  • Resolved
    Resolved

    The issue caused by MitID has been resolved, and our services are fully operational again. We apologize for any disruption this may have caused and thank you for your patience.

  • Identified
    Identified

    MidID has identified the issue affecting their systems, which is impacting our services. We are in close communication with them to ensure a quick resolution. Further updates will be provided as soon as possible.