ePay - Issue identified with MitID – Incident details
All systems operational
Issue identified with MitID
Resolved
Major outage
Started 5 days agoLasted about 5 hours
Affected
MitID
Major outage from 7:19 AM to 12:15 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
We are aware of a potential issue with MitID which is impacting some of our services. We are monitoring the situation. Updates will follow as soon as we have more information.