ePay - Investigating service disruption – Incident details

All systems operational

Investigating service disruption

Resolved
Major outage
Started 14 days agoLasted 20 minutes

Affected

Acquirer: Nets / Nexi

Major outage from 5:50 AM to 6:10 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating an issue affecting our services. Our team is working to identify the cause and will provide updates as soon as possible. Thank you for your patience.