Started about 1 year agoJune 25, 2025Lasted 4 minutesJune 25, 20251:541:58 PMUTC
Affected
MobilePay
Operational from 1:54 PM to 1:58 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
We are aware of a potential issue with Mobilepay, which is impacting some of our services. We are monitoring the situation and coordinating with their team to resolve it. Updates will follow as soon as we have more information.